Is KDE4 not ready for you? Switch to MEPIS 8

October 31, 2008

MEPIS 8 (Beta 4) below uses the latest 2.6.27-3 kernel, but stays with KDE 3.5.9 for now as Mepis emphasizes stability.  MEPIS 8 uses the Debian Lenny repos via Synaptic.  If you are a Ubuntu/Kubuntu user, you can switch almost seamlessly (with regard to your Ubuntu skills) if you want to.  Here is my current (stock MEPIS) desktop: